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1 Introduction

Netop Remote Control version 11.6 introduces extended security with Windows Azure multi-
factor authentication. The host is validated based on two factors: one authentication factor is the
Host credentials (something the user knows), the second factor is a passcode received by phone
(something the use has).

This document explains how to retrieve the Microsoft Azure information, how to configure and
connect to the host.
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2 Retrieve the Windows Azure information

1. Sign up for a Windows Azure account (link) or use your existing Windows Azure account
and login (link).

Go to Portal.

Go to ACTIVE DIRECTORY > MULTI-FACTOR AUTH PROVIDERS and click CREATE A
NEW MULTI-FACTOR AUTHENTICATION PROVIDER.

Microsoft Azure |~ CREDIT STATUS
.
@ - active directory

0

DIRECTORY ACCESS CONTROL NAMESPACES MULTI-FACTOR AUTH PROVIDERS RIGHTS MANAGEMENT
==} RECOVERY SERVICES
)

You have no Multi-Factor Authentication providers. Add one

I CREATE A NEW MULTI-FACTOR AUTHENTICATION PROVIDER @ I

@ ACTIVE DIRECTORY
1

ADD-ONS

0
g =

4. Configure a name and select the Usage model. You can also link to a directory (not
mandatory). Click CREATE.

NAME

i oo, A

Por Erabiled Uhar ]
DaRmCTORY

This mit Links @ i tannry L ]

The wapr wewie] paesor. b champnd afer e Mol Faee
Ay, afm ot vt B, P i
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5. Click the Manage icon located at the bottom of the page.

Microsoft Azure | v @ marius.ne@hotmail.com é

active directory
DIRECTORY ACCESS CONTROL NAMESPACES MULTI-FACTOR AUTH PROVIDERS RIGHTS MANAGEMENT
NAME STATUS USAGE MODEL SUBSCRIPTION DIRECTORY

My muiti factor service > o Adive Per Enabled User Free Trial

K4

FEEDBACK

6. Goto Downloads > SDK.

USER ADMINISTRATION Welcome
Block/Unblock Users

One-Time Bypass i i ) ;
Tokenless multi-factor authentication is now available to your company. If you have any questions, please contact support.

VIEW A REPORT My multi factor service
Account ID: LXSU-YM2-LGBIY

Usage
Server Status
Blocked User History VIEW A REPORT
View usage of all users of Multi-Factor Authentication within an organization

Bypassed User History

Fraud Alert
Queued ¢ CONFIGURE

Configure Multi-Factor Authentication settings such as caching, voice messages and notifications received by users

CONFIGURE
Settings ¢ DOWNLOADS
Caching Download the Multi-Factor Authentication Server

Voice Messages
Notifications

DOWNLOADS
Server
SDK
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Windows Azure Multi-Factor Authentication

# Contact Support | & He
USER ADMINISTRATION Downloads SDK

Block/Unblock Users

One-Time Bypass X - . . . . . .
Download a copy of the Multi-Factor Authentication SDK. The SDK is available in a variety of languages. Instructions for using the

VIEW A REPORT SDK are included in the archive. The Multi-Factor Authentication SDK is compatible with all Windows and Unix-like systems.
Usage
Server Status LANGUAGE ZIP TAR RELEASE NOTES

Blocked User History

! Perl Download Download View
Bypassed User History
| ; I
Eratid Alert Ruby Download Download View
Queued PHP Download Download View
ASP.NET1.1C# Download Download View
CONFIGURE :
i ASP.NET1.1VB  Download Download View
Settings
g IASP.NET 20C# Download Download \Iiewl
Caching
Voice Messages ASP.NET20VB Download Download View
Notifications Java Download Download View
DOWNLOADS Back
Server
SDK

7. Download the zip version of ASP.NET 2.0 C# and unarchive it. Open the pf folder from the

archive.
pfsdk-asp_net_2.0_cs-2_15 »
y
Name Date modified
wopf 5/19/2014 7:16 AM
= call_results 5/19/2014 7:16 AM
=] example 5/19/2014 7:16 AM
|| example.aspx.cs 5/19/2014 7:16 AM
|_| README 5/18/2014 7:16 AM
D release_notes 5/19/2014 7:16 AM
MName Date modified Type Size
b certs 5/16/2014 1:04 PM File folder
|| pf_auth.cs 5/16/2014 4:00 AM C5 File 46 KB

8. Open the pf_auth.cs file in a text editor (preferably a more advanced text editor like Word
Pad). Look for CERT_PASSWORD. This represents the password for the certificate that will
be used on the Host device.
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private const string LICEN3IE KET = & . -
private const string GEROUP EEY = '

private const stringCERT PALIIWORDY = ' "

In the pf > certs folder you can find the certificate.

The certificate and the password for the certificate represent the 2 items required from the
Windows Azure account.
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3 Configure the Host machine

3.1 Apply the Windows Azure information

In order for the machine to use the Windows Azure multi factor authentication, it needs to be
securely identified by Windows Azure. This is done by installing the Certificate obtained
previously.

The steps below are for installing the Certificate on a Windows 7 machine. This can be done
also using various mass deployment techniques (e.g.: Group Policy).

1. Run mmc.exe in order to install the certificate.

2. Click File > New. Then click File> Add/Remove Snap-in...
@ Consoled - [Console Root]

-

@ File | Action View Favorites Window Help
d Mew Ctrl+N
= Open... Ctrl+0

Save Ctrl+5

Save As...

Add/Remove Snap-in... Ctrl+M

Qptions...

1 CAWindows\system32\devrngmt

2 CAWindows\system32\compmgmit

Exit

M
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3. Choose Certificates and click Add

Add or Remaove Snap-ins “

fou can select snag-ins for this console from those avalable on your computer and configure the selected set of snap-ins. For
extermible snap-ns, you can configure which extensions are enablsd.

Aovadable grap-ns: Sajached snap-rm:
Snap-n viendor - [2 conscle Root |  EditExtensions.. |
=" ActiveX Conlrol Marosoft Cor... R
ﬂhuﬂ'ﬂqamw Murosoft Cof...

B0 Certifcates | Mirosaft Cor... |

-"‘-l:nrrmntﬁnw Mirosoft Cor.... el L

& Computer Managem... Mosaft Cor... -

2 Device Manages Merosoft Cor... | | I M D

=f Disk Management Microsoft and. .. _

HjEvmt'-':ﬂf Murosoft Cor...

| Folder Marosoft Cor...

| Group Policy Object ... Mayosoft Cor...
o [P Security Monitor Mirosaft Cor...
o [P Secunity Policy M...  Microgoft Cor...

.‘_wpm@_m M-crml‘u.‘.w - . | Advanced, ..

Desrpon:
The Certificates snap-n allows you to browse fhe contents of the cerbficate stores for yourself, a service, or & computer.

Certificates snap-in “

This snap-n will always manage certificates for:
(_)iMy user account

() Service account

(@) Computer account |

e e e e

< Back Finish || Cancel |

Copyright © Netop 2014. All rights reserved 8



NRC — Windows Azure Multi-Factor Authentication

4. Choose Computer account and click Next.

Select Computer g

Select the computer you want this snap-in to manage.

This snap-n will always manage:

(@ Local computer: {the computer this consale is running onl:

(2 Ancther computer: Browse. ..

[7] Mlow the selected computer to be changed when launching from the command line. This
onty applies if yvou save the consale.

<Back | Finish | | Canesl

A
5. Choose Local computer, click Finish then click OK.
Add or Remove Snap-ins ﬂ

You can select snap-ns for this consohe from those avalable on your computer and configure the selected set of snap-ns. For

extensible snap-ns, you can configure which extensions are enabled.

Avpiable snap-ns: ) Selected snap-ns: ) 1
Snapen Vendor . ! Console Root EditExtensions... | |
= ActiveX Control Microsoft Cor... "'"II [ ]

Remave
[T authorization Manager  Mirosoft Cor... :
G Certificates Mirosoft Cor... |2

. Companent Services  Mirosaft Cor...
A Computer Managem. . Meresaft Cer...
s Drevics Manager Microsoft Cor...

=1 Disk Management Microsoft and... L &>
|d] Event viewer Microsoft Cor...
Folder Microsaft Car...
1 Group Policy Object ... Mcrosaft Cor...
B 1P Security Moritor  Microsoft Cor...
B 17 Security Policy M. Microsoft Cor...
Surkonsi o || _ Ju—ss

Description:
The Cerfificates snap-in allows you to browse the contents of the cerlificate stores for yourself, a service, or a computer,

o< [ conce
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6. Click OK and go to Certificates > Personal. Right-click and choose All Tasks > Import...

& Console’s -xmmmcmm R
@ Fle Acon Vew Fovortes  Wimdow el
(e 20z B0
1 Concle Roet Object Type Actiom
o J Cotificates (Locet Computer)
Persensd Theee ace 50 Bemes 10 show in This veee. M.
1 Trusted Rect Cenfication A Moos Actions
Enterpeoe Trust
Inteedute Cotdicaben Ay
Trusted Publeshers
Ustrusted Cenbicates Fnd Coticanes.
Thed-Pamy Pact Cenficatan
Trusted Peogle AN Tasks . Fnd Centfucates.
Fermate Deshrop
Smart Cand Trusted Focts Fafresh Request Niew Cenficate.
Trusted Devices View . Inpant.
Asvsage oms 4 Advarced Ogerstion; .
Lne up kons
Help
- .
:CmmmlM(nkpdo-mmwa_m
Shevra: Jin®dD phnmatarvor navintdindd 1% 14

7. Click Next. Click Browse and go to the unarchived folder and open the pf > certs folder.
Make sure All files is selected in the drop-down filter. Select the cert_key.p12 file.

Certificate wizf o g
Import Wi, & Open — ‘
| Fietoimport @u.! b v pisdk-asp net 20 ¢s-2.15 » pf » cents ngb, ” Search cents »
4 Spedfy the fle ] e -
4| Orgenize v New foider = 3 @
{ -
Fle name: i Favorres *  Name Date modified Type Size |
Bl Desktop 5 cert_key 5/16/2014 400 AM  Personsl Informati...
# Downloads
Note: More thaf| 4. Recent Places
Personal Infg
Cryptographfll  L§ Libraries o
Mcrossf Sef *| Documents
o Music
e Pictures
B videos
Learn more sbout ol | 1% Computer
&L Local Disk (C)
- o« m ’
File name:  cert ey v M) v
e — Open I' I_c‘_"‘_f__!

8. Click Next. Fill in the certificate password retrieved at Step 8.
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Certificate Import Wizard - ot

Password
To maintain security, the private key was protected with a password.

Type the password for the private key,

Password:

nable strong private key protection, You wil be prompted every time the
rivate key is used by an application if you enable this option,

m

=

| Mark this key as exportable. This will allow you to back up or transport your
keys at a later time.

V! Include all extended properties.

Learn more about protecting private keys

[ <&_ad< ]L&xt) ][ Cancel J

9. Click Next, then click Finish.

10. Click Next. Make sure the Personal store is selected.

Certificate Import Wizard >
— e N T e N

Certificate Store
Certificate stores are system areas where certificates are kept.

Windows can automatically select a certificate store, or you can specify a location for
the certificate.

Automatically select the certificate store based on the type of certificate
@) Place 3l certificates in the following store:

Certificate store:
Personal

Learn more about certificate stores

| <gak || mext> | [ cancel |
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11. Click Next and then Finish. The certificate is now installed and it should appear in the
Personal folder.

!

- —
[ Cornokel - [Lonsole Reei (Ll € 4] - ==

! Corole Roct Eeved To = Thisend By Enperatecn Date  bsbended P | et

4 L Cortificater Local Compuinr) | Cetduatn =
& Pl

| Cendate Mowg Aaligeg k

] Tnased Foot Centification &

| Ertpnprie Trust
Itermnedhate Centilatesh Ai

1 Trusted Poblizhars

] Unirgrted Cortificates
Theed-Famy Rt CentioLam

| Trusmed People

| Bamcie Dmkicp

1 Svun Cad Trsted Roots
Trssted Deviies

- 1 |IF -

Fersonal sioee comaing 1 cenificate.

3.2 Configure the Host

1. Make sure the Netop Remote Control Host version 11.6 is installed.

2. Goto Tools > Program Options > Multi-Factor Services. This area allows you to add
multiple multi-factor authentication services.
Note: Once defined in this area they can be applied to different role groups as presented

below.
Program Options Jr— -
Remote Printing I Help Regquest I Run As
General Host Name | Connection Motification | Audio-Video Chat
Directory Services Multi-Factor Services | Web Update

 Multi-Factor Services

Mame | MultiFactor Service |

Qe

Edit. .. Delete

QK Cancel Help
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3. Click Add.

e Provide the service a name.

e Select Windows Azure Multi-Factor for the Multi-Factor Service Type.

e Choose the certificate that was previously installed under Client Certificate.

e The LDAP Phone No Attribute identifies the user's telephone number. It will be used to
send user the token to be used for multi-factor authentication.

e Select the Apply to all roles check box to apply the multi-factor authentication to all roles
defined in the Directory Services.

Note: Multi-factor authentication applies to all roles only if the Guest Access Method selected

from Tools > Guest Access Security is either Grant each Guest individual access

privileges using Windows Security Management or Grant each Guest individual access

privileges using Directory services.

Multi-Factor Service ﬁ

e B

— General

Marne: I My service

MultiFactor Service Type: I'L"u'indows Azure Multi-Factor LI
~ aettings

Client Certificate; Choose certificate. .. |

LDAP Phone Mo Attribute: telephoneMumber

[ Apply to all roles

Ok Cancel Help

4. Click Ok and then OK. This will finalize the configuration of the authentication service on the
Host machine.

5. In order to associate the service with actual users, go to Tools > Guest Access Security. If
Directory Services or Windows Management is used, a hew area is displayed under the
access privileges area.
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.l Guest Access Securi [ I |

Guest Access Frivileges | Guest Policy | MAC/IP Address List Setup | Encryption | Smart Card |

Guest Access Method

IGrant each Guest individual access privileges using Windows Security Management ;I

r~ Individual Guests access privileges assigned

[ §rull access Receive files from host j

(3 View only Run programs
[ Inventory only Redirect print
E} Remote Management only Remote Manage

Retrieve Inventory

Send Message

Demonstrate

Join multi Guest session

Act as multi Guest session Administrator
(% Confirm access:

(#) No

() Yes, except when

] Computer locked

] Mo user logged o
- aa0escl oOn

=] Use MultiFactor Service:

) No
Add security role | Add Group | (¥ Yes, use the following service:
Delete | Add User | INI!"I service j |

ok | cance | Hep |

This allows enabling/disabling of the Multi-Factor Authentication services per role.
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Connect to the Host machine

Make sure that the Guest is updated to the 11.6 version.
1. Connect to the device by filling in the credentials

2 Netop Guest

Connection  Edit Tools  Help

FERd = e R 2O e A0 Lo S L P R L e
[ Phonebook | 1 Quick Connect |-2ﬂi Connections " 2 Histary || &} Help Request " % Recordings " "'@f Script " b Inventory|

Host Camrunication profile
TCR/IP Address:

Wiew

Log on using Windows authentication : v |

Marne (Dptional, use with gat NETOP
y—(“j—_g— RemoteControl y [ oder= ]
Liog om ko 192,168,204, 70
E"fﬁ Connect i @ Eirin sy ey |
Gl Password: | ssssnseney
Haost 1D i Domain: | —— Infarmatian
[ k. ] [ Cancel ]

(_ | T} l|

r Metop Metwork Ii Windows Network ,l' Intel vPro ,l'

2. A passcode will be sent to your mobile phone. Fill in the passcode.

# Netop Guest

File Connecktion Edit  Wiew Tools Help

RO MRCRER o8 S el EREE LG
[ Phenebook | 1 Quick Conrect |-'!}i Caonnections || 2 Histary || &2 Help Request || 4 Recordings || “fz Script || 5o Inventor}l|

Host Communication profile
TCPJIP Address:
o o S v
Log on using Windows authentication |
Mame (Optional, use with gat NETOP" '
Delete
RemoteControl A [_peeee ]
Log on ko 192,165,204, 70
[ & .
-+ Connect @ Biro & passcode was sent ab #HHHRERR047, Blease enter it below,
Erowse list
Passcode: | | |
Host ID u Information
[ Ok ] [ Cancel ]
< Ed
r Metop Metwark " Windows Metwork ,l' Intel vPro ,l'
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The remote session has started

168.204.70 - Netop Remote C

5&3 X e G pi By I WG 8
’4 Netop: Secure remote control L] T nication - Windows Internet Explorer
@O I 2 http:ffunin.netop.com/
7 Favorites ‘ [B Suggested Sites v £] Web Slice Gallery v
! ¥ Netop: Secure remote contral, classroom manag... ‘
SignIn | Downloads | Language | Cookie Policy | Abo
Netop PRODUCTS & SOLUTIONS SUPPORT COMPANY

Meet our new best friends:
Mobile & Tablets

Our solutions for online personal service, tech
support and classroom communication can go
everywhere with you »
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5 Troubleshoot

5.1 I do notreceive any text message.

1. Check the Usage report in the Manage area. Generate a report for that timeframe and then
go to Queued area and see if the message has been sent.

USERNAME AUTHENTICATION PHONE NUMBER | AUTH'D CALL AUTH APPLICATION  MODE IHI'I'i.:'I'IHG
r—

DATE RESULT | TYPE COMPUTER SERVER IP

Text
Message
Sent

Text
Message
Sent

Text
Message
Sent

Text
Message
Could Not
Be Sent

Tevt —

2. Check the phone number. It should not contain any spaces.

5.2 Error connecting to Host. Error =100

After filling in the credentials, | get a message similar to this: Error connecting to Host. Error
= 100.

Password g

Error connecting to Host, Error = 193,

OK

l

1. Double-check the Windows Azure information. Make sure that the certificate you
downloaded and the password are correct.

2. Check | do not receive any text message.
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